Audacity

Introduction to Recording and Editing Audio

Introduction

About This Class

Audacity is an open source, free and easy to use audio editor and recorder. It includes powerful audio post-production tools to help create professional podcasts and music.

This class introduces the basic and essential concepts and interface of Audacity. By the end of the class, you will gather basic knowledge of how to import, record, edit and export your audio project with Audacity. Some more advanced editing tools will also be mentioned such as loudness normalization and noise reduction. You will also have the opportunity to record or use our excercise file to create your own podcast. We encourage you explore Audacity's other advanced features that are briefly mentioned at the end of this class.

Download Audacity

audacity logo with name

Go to https://www.audacityteam.org/download/windows/ and download the newest version of Audacity for Windows - your file will automatically download in 5 seconds! Then install Audacity by following the basic procedure of your computer operating system.

Go to https://www.audacityteam.org/download/mac/ and download the newest version of Audacity for Mac - your file will automatically download in 5 seconds!. Then install Audacity by following the basic procedure of your computer operating system.

Download the FFmpeg Library

Working with MP3, M4A (iPhone recording) files, or MP4 (video) files? You'll need to download this additional library before you can work with your audio files that aren't WAV.

For Windows:

For Mac:

Download the Class Files

From the top of this Canvas page, download the Class Files for Audacity - this is the blue link titled audacity-class-files. These will help you complete the exercise below!

Unzipping a Folder

The class files will download as a zipped folder. To be able to use the files within this folder in your Audacity project, you will need to unzip your folder first. Otherwise you may see an error when trying to import these files.

On a Windows computer:

  1. Right-click on your downloaded class files
  2. Choose Extract All... (an extraction wizard will begin)
  3. screenshot of the menu that appears after you right-click on a file on a Windows computer
  4. Click [Next >]. Click [Browse...] and navigate to where you would like to save the files.(We suggest you select the Desktop to make it easier to find later)
  5. Use these extracted (unzipped) files when completing the in-class activities

For Mac computers: double-click on the unzipped folder

Essential Tools and Edits

This section explores all the essential tasks and tools in Audacity needed to complete a basic audio project such as a podcast for a class assignment.

In-Class Activity #1:

Let's get familiar with the Audacity space and basic tools! Complete the following tasks utilizing the knowledge explained below:

  1. Open Audacity
  2. Import Audacity-info.wav from our downloaded class files folder
  3. Play the audio file
  4. Zoom in and out of the audio file
  5. Split any random part of the clip
  6. Delete the split clip
  7. Practice trimming audio clips of your choice

Opening a New Project

When you open Audacity, it will automatically create a new project for you. If you want to create an additional new project, go to File > New

image of audacity interface

Import Audio

Go to File > Import > Audio... to bring in your audio file(s) to work with. To import multiple audio files at once, hold down Command or Control and click on each file you'd like to use in your Audacity project.

Note that if you go to File > Open and select audio files, they will open in separate audacity projects instead of a single project. To ensure all audio files import into one project, make sure you go to File > Import > Audio...

Play/Pause

The easiest way to play and pause your audio file(s) is to use your Spacebar. You can also use the buttons found within the top-left area of your Audacity interface.

To play specific parts of your project, use the Selection Tool to click on any part of a clip you'd like to begin playing OR click and drag to highlight a section of any clip to play back.

Selection Tool

selection tool icon

The default tool of Audacity. Use it to select, or highlight, any part of the audio to edit it.

image of selecting part of an audio

The light blue area shows that this audio has been selected with the Selection Tool. You can hit spacebar or click the Play Button to play the highlighted section.

To select an entire clip, double click on the clip with the Selection Tool.

To select all clips within a single track, click the blue "Select" button from the left side of the track.

Can't hear your audio?

If you're using headphones (especially bluetooth) and can't hear your audio, make sure your device has been detected by Audacity.

Zoom In/Out

When working on an Audacity project, it may be helpful to zoom in and out of a clip to make more detailed edits!

Magnification Tool

magnification tool icon

Use to zoom in and out on wave forms. To zoom in, click on the waveform. To zoom out, hold the Shift Key and click on the audio.

gif of magnification tool in use

View Fit Tool

view fit tool icon

Did you accidently zoom in or out too much? Press the View Fit Tool icon and Audacity will automatically rescale your entire audio file(s) to fit your project window.

Basic Edits

Moving Clips

To move a clip, simply click on the most top part of a clip (where the name appears) and drag it where you need to. No specific tool has to be selected to be able to move a clip.

Know that you can move clips between tracks! Not sure what a track is? Read further below to learn more about how to add and remove them!

a gif showing how to move a clip within and between tracks

Is your clip not moving?

Clips will only move if they are not being "blocked" by other clips. Either move surrounding clips or zoom out enough to reveal the open spaces to move your clip to.

Trimming a Clip

Sometimes we need to shorten (trim) the length of an audio clip.

  1. Select the Selection Tool
  2. Hover over an end of a clip until you see a double arrow
  3. Click and drag to shorten a clip to your liking
  4. If you trimmed your clip too much, drag the opposite way to reveal the parts you removed
gif showing how to trim an audio clip

Duplicate

This option allows a selected audio to be copied onto a new track within a project.

  1. Select the audio clip or highlight the section you want to duplicate
  2. Go to Edit > Duplicate
  3. Move your duplicated clip as needed

Splitting Clips (Making Cuts)

We mentioned already that you can use the Selection Tool to play specific parts of a clip. You can also use the same selection method to make cuts and split your clip. Splitting clips is helpful as it allows you to create new sections of audio that you can move around or make copies of as needed.

  1. Use the Selection Tool to highlight the section you want to split
  2. Go to Edit > Clip Boundaries > Split
gif showing how to split an audio clip

After splitting a clip, you can also delete this new section. Read below to learn how!

Joining Clips

Edit > Clip Boundaries > Join: Groups seperate audio clips on the same track into one continuous clip. Use the Selection Tool to highlight multiple clips and then click Join. Notice that Audacity will connect the two clips by adding a duration of complete silence. You can drag the audio clips to join each other to avoid any complete silence. gif showing how to select audio and join them into one clip

Deleting Parts of a Clip

There are two ways to delete parts of a clip. The first method is best practice with a couple of steps, and the second method is a bit faster.

The best practice method to delete a part of a clip is to first split the section you want to remove. Doing this first will ensure you are doing non-destructive editing which means you can bring back your deleted section in the future if you need it by dragging the edges of the remaining clips!

  1. Highlight the section you want to remove and split it (refer to the steps above on how to split a clip)
  2. Click on the most top part of the splitted clip (where the clip name is located) to select the entire clip
  3. Hit the Delete or Backspace key
gif showing how to delete an audio clip

A faster way to delete parts of a clip is by using the Selection Tool to highlight the area of the part you want to erase and click on the Delete or Backspace key

This method of deleting, while very efficient in the moment, is considered to be destructive editing. This means that whatever you delete using this method is permanently deleted and cannot be brought back later on.

Fade In/Out

It's often a good idea to fade in and fade out audio (such as background music) rather than just have it start or end abruptly within a project.

Envelope Tool

fade tool icon

Use the Envelope Tool to adjust the sound level of your audio at different parts. Click anywhere once on the audio to reveal four dots on the waveform. Click once more elsewhere to create more dots and drag the points to adjust the sound level as shown by the wavelength. Make as many points as you need.

example of how to use the fade in tool to adjust volume

To adjust the sound of your entire clip, either only make one click and drag downwards as needed OR use the Amplify effect explained further down this manual.

To undo any point, either press Command Z or Control Z, or manually drag each point outside the track to reset.

Add/Remove Tracks

Tracks allow for us to essentially "layer" different audio files. For example, tracks can be helpful to layer a voiceover with some background music and occasional sound effects.

By default, a new track will be created every time you import a new audio file. But if you need to add another track manually, you can go to Tracks > Add New > Mono Track. You can choose a Stereo track, but Mono is Audacity's preferred type.

screenshot showing how to add  a new track

To remove a track, simply click on the small "x" on the most top-left corner of the track

screenshot of the 'x' to close a track

Need to Rename a Track?

Renaming a track can be helpful to organize your project a bit more. By default, your track will be named after the first imported audio. To rename, click on the down arrow next to the current name and select "Name...".

screenshot of menu that appears from clicking on the down arrow of a track

Mute/Solo Tracks

Sometimes it's helpful to only listen to one track within a project at a time while making edits. Click on "Mute" to silence that selected track or "Solo" to silence all other tracks.

mute and solo options within a track

Notice how tracks that become greyed out are tracks that have been silenced.

In-Class Activity #2:

Our first activity focused on random edits to get familiar with the program layout and basic tools. For this activity, let's pretend we are assembling a very simple podcast intro. Our project needs the following tasks completed:

  1. Delete the track labeled Audacity-info
  2. Import melodyloops-season-of-joy.mp3 and voiceover.wav
  3. Move the voiceover audio a bit to the right so we only hear the background music in the first few seconds of the project.
  4. The background music is loud! Adjust the overall volume to be softer (tip: Use the Amplify Effect explained further below for this)
  5. The voiceover is too soft! Adjust the overall volume to be louder (tip: Use the Amplify Effect explained further below for this)
  6. Fade the background music in at the beginning and out (using the Envelope Tool) before you hear the voiceover.

Essential Audio Effects

The following audio effects may be the most helpful

Amplify

While the Envelope Tool is helpful to fade audio in and out, it's often easier to adjust the volume of an entire clip with the Amplify effect. This effect also allows you to increase or decrease the volume of a clip at greater levels.

  1. Highlight the clip or select the area you want to apply the Amplify effect to
  2. Go to Effect > Amplify
  3. Select an amount (in decibals) to decrease or increase the volume of the clip.
  4. Use the "Preview" button to hear the volume levels. Note that both the Preview and OK buttons will be greyed out if the levels are too high unless you check the "Allow clipping" box. We do not recommend this, however, as parts of your audio will become distorted after it's reached its clipping limits.
  5. Once satisfied with the volume levels, click "OK".

Loudness Normalization

Sometimes our audio clips are all at different volumes and we need to match their loudness to one another. For instance, during an interview with multiple people, we may have one interviewee speak at a volume that is a bit too loud, while another interviewee is a bit more softspoken. For a podcast, this kind of variation in volumes between speakers can be distracting. It would be best to match the loudness with the Loudness Normalization effect.

Normalize Loudness Right Away

Before doing any other kind of edits, it's a good idea to normalize (match) the loudness between all the audio clips that need it at the very beginning of your project. This will ensure that other edits go smoothly.

  1. Select the entire tracks that have the audio clips that need to be "normalized" by using the "Select" button on the bottom-left corner of each track. Remember to use Command or Control to select more than one track
  2. Go to Effect > "Loudness Normalization..."
  3. From the pop-up menu, use the default settings (recommended) or adjust the LUFS to a number of your liking.
  4. Click OK
  5. Notice how your volumes between clips are now the same!
  6. Optional: Use the Amplify effect as needed after you normalize the loudness.

Noise Reduction

While it depends on the kind of project, it is often best practice to record in a quiet indoor space away from audible distractions. However, it's not always possible to get a studio-level recording space for every project. More often than not, there will be a constant hum in the background (think refrigerator, ambiant noise, random neighbors laughing at a distance). The Noise Reduction Effect will do it's best to remove as much of that background noise to make your project sound more professional.

When It's Best to Just Re-Record

While it would be lovely if the Noise Reduction effect could remove all loud background interruptions (traffic, wind, talking), this effect still has some limitations.

If too much of this effect is added to try to remove some background noise, your main audio will become distorted and much more distracting.

If at all possible, sometimes it's best to just re-record your audio in a less chaotic environment.

  1. Record your own audio, or import the noise-reduction.wav file from the downloaded Class Files into your project

  2. Use the Selection Tool to highlight some "empty" space between words within the recorded speech. This selection will be the reference point for Audacity to know what noise to filter out once we apply the effect.

    example of selecting empty space between words within the audio
  3. Go to Effect > Noise Reduction... and click Get Noise Profile

    noise reduction dialogue box with get noise profile button
  4. Using the Selection Tool, highlight all of the audio you want to reduce background noise from, and go to Effect > Noise Reduction again
  5. Increase the Noise reduction (dB) to filter out more background noise. Keep in mind that if you choose to filter out too much noise, the audio might become distorted. Always make sure to Preview your effect before hitting OK

    noise reduction dialogue box with editing options

Before Noise Reduction:

example of audio wavelengths before noise reduction

After Noise Reduction:

example of audio wavelengths after noise reduction

Recording Audio

Another way to gather audio is to record it yourself directly in Audacity. To do this, make sure you have access to a computer with an internal microphone (most laptops have one) or an external microphone.

In-Class Activity #3

For this third activity, use the effects learned above and the recording section below to complete the following tasks:

  1. Close all existing tracks within your project
  2. Create a new track and record yourself at a normal voice level
  3. Create another new track and solo it. On this new track, record yourself at a softer voice level
  4. Move the second recording to the right so it doesn't overlap with your first recording
  5. Un-solo the second track
  6. Select both tracks using the "Select" button on the bottom-left corner of each track. Remember to use Command or Control) to select more than one track
  7. Use the "Loudness Normalization..." effect to match the volume of both clips.

First, test your microphone level

  1. Find the microphone level bar at the top right of the interface, and click to start monitoring.

    gif showing microphone level bar in use
  2. Speak in your normal speaking voice to test the level, make sure your sound level locates at about -6 dB. This level helps prevent audio to go over 0 dB which often results in audio distortion, something that cannot be fixed in post production
  3. If your mic level is too low or too high, or cannot see the shifting green bar, you can change your voice volume, or adjust the microphone sensibilit on the top left.

    gif showing how to change microphone sensibility

Start Recording

Choose the type of the microphone you want to use for recording. In this case, I am using the Internal Microphone directly from my laptop.

microphone selection

Record Tool

record tool icon

Click on the Record Tool to start recording in a new track. Press the Pause Tool to take a break while recording, or Stop Tool once you finish recording.

Saving and Exporting

When you finish working with your audio files, you have several options for saving and exporting your files.

Save as Audacity Project

image of file > save project as...

Saving as an Audacity project allows you to open the project later and add further changes to your audio. The information of your multiple tracks will be saved into the project. This is the best option if you want to continue editing in Audacity. Note that this project is only compatible with Audacity, meaning you won't be able to share your creation with people who don't have Audacity downloaded onto the computer they want to open your project from.

  1. Go to File > Save Project...
  2. Choose a folder to save your project in. The default folder is named Audacity and is usually placed under Documents.
  3. Give your project an appropriate File Name so that it is easier to locate later in case you forget the folder it's saved in.
  4. Click Save to save your project as a .aup file

Export as MP3 File

If you want your audio files to have relatively good quality and smaller file size, export your audio as a .mp3 file. This is often the most popular kind of file to export as!

  1. Go to File > Export > Export as MP3
  2. Choose a folder to save your project in. The default folder is named Audacity and is usually placed under Documents.
  3. Give your project an appropriate File Name so that it is easier to locate later in case you forget the folder it's saved in.
  4. For the Format Options, usually the default will do the job
  5. Audacity will prompt you to enter metadata for the audio. Complete the form to the best of your ability and click OK.
wav file exporting metadeta form

Export as WAV File

image of file > export > export as wav

If you want to export your file to a compatible format, and you want to keep the best quality of your audio, export your audio as .wav (Waveform Audio File Format) file format. This file format is commonly used for uncompressed audio files and is compatible with most media players. It is also a larger file size compared to other formats.

  1. Go to File > Export > Export as WAV
  2. Choose a folder to save your project in. The default folder is named Audacity and is usually placed under Documents.
  3. Give your project an appropriate File Name so that it is easier to locate later in case you forget the folder it's saved in.
  4. Choose Save as type as either WAV (Microsoft) signed 16-bit PCM or WAV (Microsoft) signed 32-bit Float PCM and click Save.
  5. Audacity will prompt you to enter metadata for the audio. Complete the form to the best of your ability and click OK.
wav file exporting metadeta form

Optional Audio Effects (Only if Time Allows)

Class Activity #5 (Only if Time Allows)

If there is extra time left in class, feel free to go over this section which describes extra effects. If there is not enough time left, this section can be reviewed by each student after class if needed at their own pace.

Auto Duck

Auto Duck is an especially useful effect for podcasting. The effect reduces (ducks) the volume of one or more selected tracks automatically whenever the volume of a single unselected "control track " placed underneath reaches a particular threshold level. For example, you can have the volume of the track with background music reduce once the track with a voiceover is introduced at a certain volume.

  1. Import the music file melodyloops-season-of-joy.mp3 and voiceover.wav file. Make sure the music file is on the track above the track of the voiceover file. If not, click on the small triangle next to the audio name, and choose Move Track Down

    gif showing how to move a track below another one
  2. Using the Selection Tool, highlight the entire music file and go to Effect > Auto Duck
  3. Adjust the Duck amount and outer and inner fade up/fade down length. The lower the dB of the Duck amount, the lower the volume of the music will be once the voiceover appears. The Outer fade down/up length is the amount of time it takes to gradually fade the music out or in before the voice audio enters. The inner fade down/up length is the amount of time given to continue the fade after the voice audio enters. Remeber to always Preview your edits before clicking OK.

    auto duck dialogue box with editing options
  4. Press OK once you're done. Below is an example of a music file before and after the Auto Duck Effect:

BEFORE AUTO DUCK:

image of audio wavelength before auto duck effect added

AFTER AUTO DUCK:

image of audio wavelength after auto duck effect added

More Audio Effects

Audacity includes many audio effects for more advanced audio editing. To apply an effect, first use the Selection Tool to highlight the area of the audio you want to modify. Then, from the Effect menu, select an effect option to add to the selected audio.